Hi, I just upgraded my beta to and I'm hitting an issue with the variable handling.  Normally, whenever a new version comes out, variables fluctuate between showing up as quote-encapsulated and not.  It normally doesn't affect functionality other than sort order and it's a beta, so no big deal.  This time around it's doing something new.

My automation basically sets a variable (#TODAY#)  which generates today's date in YYYY-MM-DD format as a string.   I then use that variable to name my query export and then in my notification emails, I provide a url with the filename for the day.  It's all pretty simple stuff. 

The export now exports the filename without quote-encapsulating the date portion, which is how I'd prefer it.  However, every other step in automation is still using & looking for the quote-encapsulated version, so parts of the job start failing.  I've tried simple things like the copy file action and my email notification action and they all fail.  

E.G.  I'm generated Filename_2017-08-11.xlsx and the rest of the job is looking for Filename_'2017-08-11'.xlsx ,  even though every step refers to the same #TODAY# variable.   

I've tried rebuilding the variable  as Date('YYYY-MM-DD') and to_char(Current_date(), "YYYY-MM-DD') and both behave the same way.    I've also tried setting it as a DateTime variable, which introduced new issues. 

Is there something I'm missing to get this to behave consistently ?